Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L D4D

Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L D4D

Postby suzukidave on Thu, 11 Jul 2019 6:12 +0000

Hi all,

I have a check engine light, with a P1052 code showing on my 2013 Hilux SR5 (1KD-FTV 3.0L diesel)
This code indicates high voltage on oxygen sensor bank 2 sensor 1.
This would confirm why the engine is rattling like crazy and won't run for more than a few seconds.
I'm actually a bit worried I've damaged it running for just a few minutes in this condition.
I want to locate the bank 2 sensor 1, unplug it, measure the voltage through the lead (with key on/engine off) to determine if it's a wiring problem or a faulty sensor.
Can anyone help me locate the sensor?

Cheers

David
suzukidave
 
Posts: 6
Joined: Wed, 12 Apr 2017 4:08 +0000
Location: Seddon, Victoria


 

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby mitch_893 on Mon, 15 Jul 2019 3:56 +0000

Almost certain it does not have an o2 sensor.

It’s common for non genuine code readers to give the wrong description for a dtc.
06' D4D dual cab SR
Build thread

Cheers!
User avatar
mitch_893
 
Posts: 631
Joined: Thu, 14 Jul 2011 8:26 +0000
Location: Mornington Peninsula.

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby TOYZX on Mon, 15 Jul 2019 4:33 +0000

Sounds like a code for a v6 petrol!

Sent from my SM-G955F using Tapatalk
User avatar
TOYZX
Moderator
 
Posts: 2804
Joined: Wed, 08 May 2013 7:58 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby hiluxxury on Mon, 15 Jul 2019 4:59 +0000

Definitely no O2 sensor on the 1kd.

Have you done anything to the car lately?
User avatar
hiluxxury
Moderator
 
Posts: 595
Joined: Sun, 20 Dec 2009 4:16 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby suzukidave on Thu, 18 Jul 2019 8:07 +0000

Thanks for the replies, I think I have a lead on this problem now.
I scanned again with the engine actually running (yes I had been scanning with key on/engine off - doesn't give good results) and got a p0200 code.
Anyhow, I found another thread on here describing exactly the same rattle and rough idling and it turned out to be a fried injector driver that came about to due to voltage spike a clutch start.
I remembered that I had accidentally created a short across the battery terminals and blown the main 10amp fuse on the active lead from the battery - right before this problem started. It wouldn't be surprising if I had damaged something else in the process.
Now I'm looking for a way to test my injector driver. Any ideas on this?
Would be a lot easier with access to the Toyota repair manual. Haynes one doesn't cover this.
suzukidave
 
Posts: 6
Joined: Wed, 12 Apr 2017 4:08 +0000
Location: Seddon, Victoria

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby hiluxxury on Fri, 19 Jul 2019 5:52 +0000

Yeah mate, the P0200 error can point to a variety of things, including the wiring/connectors, the EDU (driving unit), the ECM (control module), one or more injectors, or a combination of these.

Some basic testing can be found here:
http://www.baileysdiesel.com/wp-content ... 200-97.pdf

I recommend consulting a good auto electrician, or a Toyota dealer. Once you know whats causing the problem, you can still decide to do the repair yourself.
User avatar
hiluxxury
Moderator
 
Posts: 595
Joined: Sun, 20 Dec 2009 4:16 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby suzukidave on Sat, 20 Jul 2019 4:19 +0000

So I got hold of the toyota repair manual for the car (1 day subscription online) and followed right through the diagnostic procedure for P0200, checking resistance of all the injectors (fine), wire harness (fine), EDU to ECM harness (fine) and voltage circuit from battery to EDU (12.54V - also fine).
Following the repair manual this leads you to the conclusion there is an open circuit in the EDU somewhere causing the problem.
Planning to order the EDU (DENSO driver injector - part # 89871-25010) and install it myself, but wondering what the hell the crackling/electrical noise is coming from the part I've taken photos of (it's not the EDU):

The noise can be heard with key on/ engine off, pretty sure it's not normal - any ideas?
Photos below - I've circled the part, I think it's something to do with the EGR.
https://drive.google.com/open?id=1L9JlT ... E05OwjnE9g
https://drive.google.com/open?id=1c6Ko_ ... Ea0j5UwHuD
suzukidave
 
Posts: 6
Joined: Wed, 12 Apr 2017 4:08 +0000
Location: Seddon, Victoria

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby hiluxxury on Sat, 20 Jul 2019 4:52 +0000

Its the turbo stepper motor. Its normal for them to make some noise
User avatar
hiluxxury
Moderator
 
Posts: 595
Joined: Sun, 20 Dec 2009 4:16 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby suzukidave on Sat, 20 Jul 2019 8:16 +0000

Alrite, good to know thanks. I hadn't noticed that noise before.
I'll update once I've changed the part.
suzukidave
 
Posts: 6
Joined: Wed, 12 Apr 2017 4:08 +0000
Location: Seddon, Victoria

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby TOYZX on Sat, 20 Jul 2019 8:27 +0000

Yep x2, they can be noisey little buggers! Not uncommon for them to fail either.

Sent from my SM-G955F using Tapatalk
User avatar
TOYZX
Moderator
 
Posts: 2804
Joined: Wed, 08 May 2013 7:58 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby Mrmal on Sun, 21 Jul 2019 6:08 +0000

X3 on the stepper motor, code came up on the brothers ute and toyota tech said it was unlisted code that linked to either the motor or the driver unit. We replaced the driver unit and problem went away.
Mrmal
 
Posts: 194
Joined: Tue, 16 Jul 2013 11:26 +0000

Re: Bank 2-Sensor 1(oxygen sensor) location 2013 hilux 3.0L

Postby suzukidave on Sat, 03 Aug 2019 5:33 +0000

I put the new driver injector in today and all is well with motor again - cleared the DTC and it's running as normal with no reappearance of engine light. :D
suzukidave
 
Posts: 6
Joined: Wed, 12 Apr 2017 4:08 +0000
Location: Seddon, Victoria


Return to Electrical

Who is online

Users browsing this forum: No registered users and 3 guests