engine loss of power no check engine light in dash

Turbo, Manifolds, Exhaust, Intercooler, Internals etc

engine loss of power no check engine light in dash

Postby lytspid on Mon, 08 May 2017 10:51 +0000

Hi Mates, id like to ask your opinions on this, my hilux with 3.0 1kd ftv has been remapped we change turbo using f55v using the original vnt actuator, after 1 month of use the problem arises , i have a limp mode but with no check engine light , then i have it scanned for any error, theres nothing to read all is normal, the engine would not go past 3000rpm just like getting a check engine light,,we already block the egr,check the air cleaner, fuel filter all is good, the problem would come even at low rpm and normal driving. sometimes to remedy the problem we will turn off the engine for a while then restart it ,and its back to normal again,maybe you can help me check some areas we might have not look into? your opinions and suggestions are greatly appreciated ,thanks in advance,
lytspid
 
Posts: 6
Joined: Fri, 14 May 2010 6:48 +0000


 

Re: engine loss of power no check engine light in dash

Postby TOYZX on Tue, 09 May 2017 4:51 +0000

No something really simple like an air lock in the fuel system??

Sent from my SM-N920I using Tapatalk
User avatar
TOYZX
Moderator
 
Posts: 2850
Joined: Wed, 08 May 2013 7:58 +0000

Re: engine loss of power no check engine light in dash

Postby lytspid on Tue, 09 May 2017 7:13 +0000

no airlock sir,, we've double check everything all is good, is this a symptom of scv going bad?
lytspid
 
Posts: 6
Joined: Fri, 14 May 2010 6:48 +0000

Re: engine loss of power no check engine light in dash

Postby TOYZX on Wed, 10 May 2017 4:52 +0000

Could be, ya need to get it on a scan tool and go for a drive so ya can watch ya fuel pressure (and everything else) in real time. Mite show up a provlem.

Sent from my SM-N920I using Tapatalk
User avatar
TOYZX
Moderator
 
Posts: 2850
Joined: Wed, 08 May 2013 7:58 +0000

Re: engine loss of power no check engine light in dash

Postby russp on Fri, 17 Jan 2020 6:41 +0000

Hi Lytspid,
Did you manage to solve this problem?
My Hilux is exactly the same as yours and I have exactly the same issue.
Loss of power, no check engine light or fault codes.
when towing it can barely do 80kms/h @ 3500rpm. Reving it’s Tits off.
Everything goes back to normal if the car is let idle for 10mins, but will lose power after 10mins of driving again.
No check engine light or fault codes. I’ve replaced fuel filter, air filter and clean air intake sensor.
Taken to Toyota, but nothing. Taken to a diesel mechanic, but nothing.
Almost runs ok without towing, but I can notice power loss.
Injectors recently replaced about 10K ago, but just started happening in the 500 kms
russp
 
Posts: 1
Joined: Thu, 27 Jun 2013 6:08 +0000


Return to Engines

Who is online

Users browsing this forum: No registered users and 5 guests