post egr clean

Turbo, Manifolds, Exhaust, Intercooler, Internals etc

Re: post egr clean

Postby Liam1994 on Sun, 24 Jan 2016 1:23 +0000

Follow
Have you figured the resoulution out for this yet I have the exact same issue!!
Have tried all above listed repairs and still no change
Car isn't in limp mode but can't get rid of this engine light
I have the same po400 code
Liam1994
 
Posts: 6
Joined: Sat, 23 Jan 2016 5:46 +0000
Location: Deer Park


 

Re: post egr clean

Postby fourby4diesel on Sun, 24 Jan 2016 2:56 +0000

What exactly did you do to the vehicle?
New DENSO Injectors are the go! New genuine parts.
Cheers, Anth - Technician - 1KD-FTV

Check your injectors about every 10,000k.
WARNING check oil pickup screen is clear
no chips no tune ups - why increase risk of piston cracking?
User avatar
fourby4diesel
 
Posts: 813
Joined: Mon, 11 Apr 2011 7:26 +0000
Location: Melbourne

issues after egr and intake clean

Postby nathanjd92 on Wed, 17 May 2017 6:26 +0000

Hi all, please bear with me as this may seem like a pretty stupid question, I recently cleaned the egr and intake on my 09 TD hilux (145000kms on the clock) as per the write up from a member on here, whilst removing the 2 vacuum hoses from the intake and thanks to my missus who snuck in and scared the absolute **** out of me I put a small hole in one of them. Being 10pm on a Sunday night and work the next day I wrapped some electrical tape over the hole as best I could, it's now that on first start up it had a very rough idle for about 30secs which I'm assuming is the hole in hose but also the temp gauge went straight to normal operating temp. Any ideas on whether it's the broken hose and my dodgy fix doing this or something else? Oh and yes I am replacing the hose when I get back from work on Friday so I'll soon see but just for the moment any other thoughts? :?
nathanjd92
 
Posts: 20
Joined: Wed, 12 Nov 2014 7:26 +0000
Location: toowoomba

Re: post egr clean

Postby DeadlyBeast on Wed, 17 May 2017 10:17 +0000

Threads merged
Have a look thru this thread Nathan.
Some useful leads
________________________
2007 SR5 D4D Auto
2014 SR D4D Auto
Build Thread
DeadlyBeast
Moderator
 
Posts: 1861
Joined: Sat, 26 May 2012 7:42 +0000
Location: Top End

Re: post egr clean

Postby nathanjd92 on Thu, 18 May 2017 3:51 +0000

DeadlyBeast wrote:Threads merged
Have a look thru this thread Nathan.
Some useful leads

Thanks Deadly beast I shall check and recheck everything when I replace the lines and see how I go
nathanjd92
 
Posts: 20
Joined: Wed, 12 Nov 2014 7:26 +0000
Location: toowoomba

Re: post egr clean

Postby Shea on Wed, 16 Sep 2020 10:39 +0000

Hello, hope everyone is going well. I can't find where this thread continued, I have seen it come up in a few other places but am having the exact same problem with my 2011 hilux which recently had a reconditioned motor put in. I believe the egr valve was also cleaned out and all was good for a few days then the engine light came on but no limp mode or noticible loss of power. Would it be the electrical component of the egr valve and should I be being a new egr valve? I think they are about $600. Cheers for the info!
Shea
 
Posts: 3
Joined: Tue, 20 Dec 2016 11:24 +0000
Location: Perth WA

Re: post egr clean

Postby Gipsy on Wed, 16 Sep 2020 2:34 +0000

First get an OBD2 scanner and read the codes, an engine light will leave a code in the ECU. Once you know the code it will give you some idea on what's wrong. You can buy a Bluetooth OBD2 scanner for less than $50
Cheers Gipsy :D
My 2013 auto D4D DC SR5, prefilter, 3" exhaust and Chip with egt probe
Gipsy
 
Posts: 1394
Joined: Tue, 07 May 2013 2:00 +0000
Location: South Coast NSW and all over Oz

Re: post egr clean

Postby Shea on Thu, 17 Sep 2020 3:17 +0000

Cheers for the reply Gipsy, the codes it is putting out are P0400 & P0406, the auto electrician at Toyota near me is quite certain I will be needing a new EGR Valve due to the electrical side of the one in there malfunctioning. It is a pretty expensive part and I've seen a few other people with the exact same issue on here though so thought I would see if anyone else had solved it before getting a whole new valve.
Shea
 
Posts: 3
Joined: Tue, 20 Dec 2016 11:24 +0000
Location: Perth WA

Re: post egr clean

Postby Gipsy on Fri, 18 Sep 2020 6:35 +0000

Cheers Gipsy :D
My 2013 auto D4D DC SR5, prefilter, 3" exhaust and Chip with egt probe
Gipsy
 
Posts: 1394
Joined: Tue, 07 May 2013 2:00 +0000
Location: South Coast NSW and all over Oz

Re: post egr clean

Postby hiluxxury on Fri, 18 Sep 2020 7:57 +0000

x2 with what Gipsy said. There is also a diagnostic test for the P0406 code you can do here:
http://www.baileysdiesel.com/wp-content ... hecked.pdf

Some people have solved this by taking out the egr and put it back together checking all electrical connections and vacuum hoses. Be worth doing before spending the $600
User avatar
hiluxxury
Moderator
 
Posts: 961
Joined: Sun, 20 Dec 2009 4:16 +0000

Previous

Return to Engines

Who is online

Users browsing this forum: No registered users and 2 guests