Help weird electrical Problem 2010 Hilux Diesel

Re: Help weird electrical Problem 2010 Hilux Diesel

Postby martynvella on Tue, 24 Nov 2015 4:15 +0000

Just re read your original post, forgot it is a 15 model,

Don't touch it, take it to a dealer if you haven't fitted extra reverse lights.
martynvella
 
Posts: 1097
Joined: Fri, 20 Sep 2013 1:59 +0000
Location: Sunshine Coast


 

Re: Help weird electrical Problem 2010 Hilux Diesel

Postby xychix on Thu, 07 Jan 2016 8:20 +0000

If its warrantly let the dealer handle it, if the excellent port of Martynvella didn't get you there have a look to all other stuff that might be connected to reverse lights / switch (For example trailer reverse lights? Loads of conducting stuff in the connector might give similar issues)

Hopefully it's resolved already, would be great to know what was diagnosed in the end :)
xychix
 
Posts: 218
Joined: Thu, 05 Nov 2015 10:43 +0000
Location: holland

Re: Help weird electrical Problem 2010 Hilux Diesel

Postby bennyo on Sun, 29 May 2016 7:39 +0000

I just had a similar problem, 2012 D4D. Drove it Friday with no problems. Replaced a cracked tail light assembly this morning with a $50 Ebay one, then went out in wife's car. Tonight went to drive the Hilux and found that my AC, blinkers, reverse lights, power windows, power heat and fan weren't working. Radio, wipers/washers, hazards, headlights, dash lights & remote central locking were OK. It seemed strange to me that the blinkers didn't work individually but the hazards and flash on lock/unlock were fine. I took the tail light back off, replaced the new wiring harness with the OEM one, then when the problem persisted went looking for a blown fuse.

Found that it was the 10A ECU/IG & Gauge fuse on the driver's side. Absolute pain in the arse to get my big clumbsy fingers in there to get it out, even with the supplied tool. Here's hoping that there was something wrong with the harness on the new tail light and I don't have to do that fuse again.
bennyo
 
Posts: 28
Joined: Wed, 05 Oct 2011 11:30 +0000

Re: Help weird electrical Problem 2010 Hilux Diesel

Postby 01Turbolux on Sun, 28 Aug 2016 2:30 +0000

Turned out to be the switch on the gear box that signals reverse is engaged. Toyota replaced it and all good now
01Turbolux
 
Posts: 9
Joined: Thu, 19 Nov 2015 3:37 +0000
Location: Wangaratta

Re: Help weird electrical Problem 2010 Hilux Diesel

Postby K_east88 on Wed, 10 Oct 2018 5:46 +0000

G'day fellas this problem is happening to me now, its a 2012 ive got two sets of reverse lights checked them this afternoon. Its fine when i put it in reverse but as soon as i push the clutch in it blows... Any ideas??
K_east88
 
Posts: 12
Joined: Tue, 12 May 2015 5:31 +0000
Location: Mermaid Waters, QLD

Previous

Return to Electrical

Who is online

Users browsing this forum: No registered users and 1 guest