No brake lights

No brake lights

Postby Sarantlux on Sat, 01 Aug 2020 1:03 +0000

Hi all, I have a problem where my brake lights don’t work but the tailgate one does. I have found zero volts on both sides. I have a genuine trailer plug controller which I have checked. It seems like it could be ground problem but I would expect the other lights not to work. The relay stops all the brake lights when I remove it so it’s seems fine. Thanks for your help.
Sarantlux
 
Posts: 1
Joined: Mon, 14 Nov 2016 6:35 +0000
Location: Gladstone QLD


 

Re: No brake lights

Postby numberplate on Sat, 01 Aug 2020 2:48 +0000

wouldn't happen to be 2 blown globes by any chance? check the wiring harness for any points where it may have rubbed through.
numberplate
 
Posts: 282
Joined: Mon, 10 Oct 2016 3:31 +0000
Location: QLD

Re: No brake lights

Postby Bushwalker8 on Sun, 02 Aug 2020 8:25 +0000

The trailer module/ECU sources it's light signals via two patch cables inserted into the looms at the tail lights. There is a patch for each side, the brake light signal is sourced from the RHS tap. You could also check for a stop signal at the trailer connector.

If there is a problem with the way either or both taps have been installed then it could be possible the brake light signal may not be passing through to the vehicle lamps.

Check the connections on the taps, and if you want to eliminate the taps then temporarily remove them and plug the main loom directly into the lights as they would be on any vehicle without the trailer ECU.
If they are still not working check the voltage in the connectors on the main loom in case any pins may have been damaged in the installation. Stop signal is pin 4, red/black wire on the RHS & grey/black wire on the LHS.
Bushwalker8
 
Posts: 80
Joined: Fri, 02 Sep 2016 6:59 +0000
Location: Geelong, Victoria


Return to Electrical

Who is online

Users browsing this forum: No registered users and 2 guests