Electrical issues

Electrical issues

Postby wbute on Wed, 05 May 2021 5:22 +0000

Hi, my 2011 SR5 Hilux is driving me insane. It’s fairly high km at 350000km. It has now developed some intermittent issues.
The ABS and traction control lights come on randomly, no common trigger that I have noticed. The cruise control works sometimes, but sometimes when the ABS lights are on, the cruise control icon just flash’s on and off. Sometimes when turn the headlights on, the throttle stops working until I lift my foot off and push it back down. The cruise control never works when the lights are on.
Think it’s time to turn it into a farm Ute. Just too much electrical crap in these cars and it’s only getting worse. We have Hiluxes at work (mine) and the green death gets into the wiring harnesses in about 6 months. You can’t get them into 4wd and the dash lights just stay on constantly. It’s not just the Hiluxes though, all brands suffer from it. If you go back the old HJZ79 style, they lasted way longer.
wbute
 
Posts: 20
Joined: Sat, 03 May 2014 6:24 +0000


 

Re: Electrical issues

Postby martynvella on Wed, 05 May 2021 5:44 +0000

Sounds like a harness problem.
Try removing both tail light fittings and unplugging them, if this then allows the cruise control to operate with the lights on then it will narrow one or all of your problems down to a rear harness fault, possibly as simple as a corroded ground point, could also be a corroded stop/tail bulb holder or even a faulty bulb.
Put your tail lights on and have someone press the brake pedal, do both lights do as expected?
martynvella
 
Posts: 1327
Joined: Fri, 20 Sep 2013 1:59 +0000
Location: Sunshine Coast

Re: Electrical issues

Postby wbute on Wed, 05 May 2021 10:44 +0000

Righto. I have a blown tail light globe so I will check that. It’s a one tonner so they are just after market tail light assemblies.
wbute
 
Posts: 20
Joined: Sat, 03 May 2014 6:24 +0000


Return to Electrical

Who is online

Users browsing this forum: No registered users and 2 guests